Suggestion for flair help re-feature

Dear FLAIR Team
Suggestion that the help feature in the old Flair program was more helpful to me than the new one … as the new one gives all the indicators of the manual and you have to rewrite or search about what you want. While the old feature gives directly what you are searching for, it directly gives what you are looking for when you press F1 or Help
I suggest to focus the F1, for example, for fixed and definite search topic directly while other icon can be for the whole body of the manual

best regards

1 Like

Dear FLAIR team,
indeed @mohammed.fayiz is right and I share his thoughts on that.

Best wishes,

1 Like

Hi @mohammed.fayiz @Ivan
in the last versions of both fluka and flair a big effort went to restructure the manual and convert it to restructure text format so as from a common source to generate other formats like html, pdf, with a lot more formatting capabilities

The old help browser in flair was not able to show the html formatted help, so now flair is forced to use external viewers.

You have the option from the flair preferences to either select as viewer your favorite web-browser or you can install the pywebview python plug in.

When hitting F1 flair is asking the browser to show the corresponding page as in the past.

If this is not happening I would advice either to check with a different browser (setting as default on your system) or preferably install the pywebview as
pip install pywebview

if it still fails for you, please tell us what system you are using, and the default web browser to be able to debug the issue

1 Like

Hello @vasilis !

First of all. Thanks for your efforts! In general the new manual looks amazing!

The problem is that I tried both options and the thing is that info button opens the main page of the manual all the time (index.html), but in previous version of Flair this info button (or F1) showed the page of manual appropriate to the selected card in Flair. Also, you can see the output in terminal after I push the info button.


- help(‘/usr/local/flair/manual/html/index.html’)
Bottle v0.12.23 server starting up (using WSGIRefServer())…
Listening on
Hit Ctrl-C to quit.

Bottle v0.12.23 server starting up (using WSGIRefServer())…
Listening on
Hit Ctrl-C to quit. - - [19/Jan/2023 11:29:27] “GET /index.html HTTP/1.1” 200 41624 - - [19/Jan/2023 11:29:27] “GET /_static/pygments.css HTTP/1.1” 200 4819 - - [19/Jan/2023 11:29:27] “GET /_static/flair_rtd.css HTTP/1.1” 200 6081 - - [19/Jan/2023 11:29:27] “GET /_static/documentation_options.js HTTP/1.1” 200 421 - - [19/Jan/2023 11:29:27] “GET /_static/jquery.js HTTP/1.1” 200 89501 - - [19/Jan/2023 11:29:27] “GET /_static/underscore.js HTTP/1.1” 200 19530 - - [19/Jan/2023 11:29:27] “GET /_static/_sphinx_javascript_frameworks_compat.js HTTP/1.1” 200 4418 - - [19/Jan/2023 11:29:27] “GET /_static/doctools.js HTTP/1.1” 200 8171 - - [19/Jan/2023 11:29:27] “GET /_static/js/theme.js HTTP/1.1” 200 5023 - - [19/Jan/2023 11:29:27] “GET /_static/css/theme.css HTTP/1.1” 200 129674 - - [19/Jan/2023 11:29:27] “GET /_static/css/fonts/lato-normal.woff2?bd03a2cc277bbbc338d464e679fe9942 HTTP/1.1” 200 182708 - - [19/Jan/2023 11:29:27] “GET /_static/css/fonts/fontawesome-webfont.woff2?af7ae505a9eed503f8b8e6982036873e HTTP/1.1” 200 77160 - - [19/Jan/2023 11:29:27] “GET /_static/css/fonts/Roboto-Slab-Bold.woff2?9984f4a9bda09be08e83f2506954adbe HTTP/1.1” 200 67312 - - [19/Jan/2023 11:29:27] “GET /_static/css/fonts/lato-bold.woff2?cccb897485813c7c256901dbca54ecf2 HTTP/1.1” 200 184912 - - [19/Jan/2023 11:29:27] “GET /_static/css/fonts/lato-normal-italic.woff2?4eb103b4d12be57cb1d040ed5e162e9d HTTP/1.1” 200 195704

(process:104284): GLib-CRITICAL **: 11:29:28.551: Failed to set scheduler settings: Operation not permitted

I am using Ubuntu 20.04.5, default browser is Chrome ver. 109.0.5414.74. pywebview 4.0


1 Like

Thanks for the information @Ivan
on my setup ubuntu 22.10 it works as it is supposed (at least on what I’ve tried). So I will try on a virtual machine with your setup to understand what can be the problem

1 Like

Dear Vasilis Vlachoudis @vasilis

I’m using Google Chrome Version 106.0.5249.119 (Official Build) (64-bit) under UBUNTU version 20.04 LTS

In the Preferences under Manual viewer there is
i- webview gives nothing
ii-webbrowser directed to file:///usr/local/flair/manual/html/index.html

iii- At any place in the flair pages F1 or i or press help, in the edit card mode, you are directed to

best regards

I’ve just tested it on my Virtualbox XUbuntu 20.04LTS

  • with pywebview it doesn’t work correctly, the default webkit browser rendering is bad and it doesn’t show the correct page.
  • with webbrowser as setting it opens firefox and I get the correct page. I’ve tried also removing firefox and installing google chrome and it works ok.
1 Like

But seems that for both @mohammed.fayiz and me neither pywebview nor webbrowser opens correct page it’s the main page all the time. Just tried with Firefox still the same…

1 Like

I understand, that there is a problem, however I cannot reproduce it. I will try to install a fresh Ubuntu 20.04LTS (not xubuntu) and test again

1 Like