Trying to install FLUDAG

I need help install FLUDAG.
The problem happens when I try to do “make” to build FLUDAG:

Linking CXX shared library libfludag.so
/usr/bin/ld: cannot find -lFLUKA_LIBRARIES-NOTFOUND/libflukahp.a
collect2: error: ld returned 1 exit status
src/fluka/CMakeFiles/fludag-shared.dir/build.make:102: recipe for target ‘src/fluka/libfludag.so’ failed
make[2]: *** [src/fluka/libfludag.so] Error 1
CMakeFiles/Makefile2:1984: recipe for target ‘src/fluka/CMakeFiles/fludag-shared.dir/all’ failed
make[1]: *** [src/fluka/CMakeFiles/fludag-shared.dir/all] Error 2
Makefile:140: recipe for target ‘all’ failed
make: *** [all] Error 2

I’m not being able to solve it.

Help would be welcome. Thank you.

Dear Duarte,

I remembered that you already asked about FLUDAG in this topic:

did you try to install from the linked repositories “fluka-cern” branch? The error message suggest the FLUDAG tries and fails to link a different version of FLUKA.

Cheers,
David

Hello, David,

I am trying to intall from the linked repositories you mentioned. I am using the latest version of FLUKA…

Thanks,
Duarte

HI Duarte

Just to be absolutely sure, you have checked out my branch from the repo. You must also set the appropriate FLUKA_DIR, command on the cmake line e.g.

cmake .. -DBUILD_FLUKA=ON -DFLUKA_DIR=/home/adavis/opt/fluka/fluka4-0.1/ -DMOAB_DIR=/home/adavis/opt/moab -DBUILD_STATIC_LIBS=OFF

I’ve just build from that branch against FLUKA-4.01 and it built fine, are you using a different version?

Thanks

Andy

Hello, Andy,

Thank you for your patience.

I am positive: I am using what I download from your repo and FLUKA4-0.1.

I tried setting the appropriate FLUKA_DIR and yeat I get the same error.

Thanks,
Duarte

1 Like

Dear Duarte,

did you manage to install FLUDAG?

I was able to do so with FLUKA 4-1.1 following the guides from DAGMC’s official site: Installing dependencies — DAGMC and Install FluDAG — DAGMC

The only change I did was to replace the lines:

git clone https://github.com/svalinn/DAGMC
git checkout develop

with

git clone https://github.com/makeclean/DAGMC.git
git checkout fluka-cern

Cheers,
David

Hello,

I finally succeeded in installing FLUDAG. I had to do:

git clone https://github.com/makeclean/DAGMC.git
git checkout fluka-cern

and I had to set the proper FLUKA path in the cmake.

Thank you both.

Kind regards,
Duarte