Voxel material reading Error

default.txt (1.5 KB)
newconver.txt (206.6 KB)
Dear Fluka experts!
I am now working on a project which need introduce a voxel material phantom into monte carlo scope.Since I have special requirments in this project, i write a new .mat file to build my phantom.So I write a new HU-Material convertion table

Then I build a voxel phantom through this mat file sucessfully, and builc it in my inp file

However, the material information is error , showing an error remind in geometry like this

At first i think the error may comes from the new mat file so i test the vxl builc process with a regular dicomct and default mat file. This error occurs again, so i am now wondering if there any solution for this error. I attached all vxl and .mat file here. Thank u so much for your help!

default.txt (1.5 KB)
Here also the error report:

newconver.txt (206.6 KB)

Dear Richard,

Thanks for your question, we will soon look into it. Could you please complete your question by adding also flair and/or input file, so that I can reproduce the error message?


Dear Marco
Here is the code and attached vxl file , you can get access to all files here,Thank you so much for your kind help! flukacode.zip - Google Drive

Dear Richard,

It is still not entirely clear to me what might be your problem, but I have a few considerations:

  • I opened your dualct2.flair file and I found that the VOXEL card had a wrong filename, I chaged it alternatively to the two .vxl files you provided (default.vxl and newconver.vxl), however, also for me the voxel regions did not have a material assigned → there might be something wrong with both files.
  • Then I decided to create a .vxl file from scratch starting from a dicom example file that I found on the web (.dcm), to test your newconver.mat file:
    • first I used for the material definition head.mat (a file provided in the Flair webpage, in section Auxiliary files) → this worked fine and created the desired geometry (see picture below)

    • then I used newconver.mat and in this case I got the same error message you are receiving (se picture below).

To me, there is something wrong with newconver.mat, but also probably with default.vxl and newconver.vxl.
Can you please try to re-generate your .vxl file starting from your dicom file and using, for the materials, head.mat (download it from the Flair webpage, in section Auxiliary files)? To create the .vxl file, I would suggest you to follow the steps provided in this thread: RT-planning example using Fluka.

I hope this can help you,

Dear Macro
Thank so much for your knid help! i have already find the error source, it might attribute to the wrong material defination. I then build new compound material and load it into user defined material scope, the load of new developed vxl seems works well now. Appreciate your suggestion!
Richard Lee