Increase Gnuplot margins

Greetings Experts,

I have run a sample simulation that generates one plot via USRBIN (22 BIN). When plotting this file, the right most energy deposition heat bar is cut off, so that some exponents and any labels are cut off. I am unsure if this is a GNUPLOT issue or one with flair. Please advise. I have attached the FLAIR file and a .eps output of the plot. Thank you kindly for your time.

Cheers,
Rick

practice_3_Rb_box.flair (3.8 KB)

Hi @rick,

This is an issue with gnuplot, the color bar doesn’t fit automatically on the margin. You can increase it with the following gnuplot commands:

set lmargin screen 0.1
set rmargin screen 0.8

See the picture, where you need to put these lines:

One extra tip, if you click on Title, then Auto, you can set the correct aspect ratio for the axes.

4 Likes

Following @horvathd suggestion you can make the settings in gnuplot permanent by adding them in the file ~/.gnuplot
Another suggested option is the set format "%h"

3 Likes

Thank you, @horvathd and @vasilis, your solutions and explanations are very helpful. I especially appreciate @horvathd 's picture explanations.